Coming soon: Your brand new Help Center & Community! Get a sneak-peek here

Execute Wscript as a document/template

Hi,

I am trying to make a vbs-script as a template. When opening the created document (xxx.vbs) created in the Activitites it is opened by Notepad. How do I make SuperOffice open the script with the Wscript host?

When creating the template there are some Registry options (Open, Edit and Print) - how are they supposed to be used?

This is what I have tried:

Registry options in templates

 

RE: Execute Wscript as a document/template

Hi again,

Found out how it - somehow - works..Registry option  Edit

SuperOffice opens the document in "Edit"-mode and above seems to work.

However, only if there are no SPACES in the file name?!?

I tried both "%1" (does not work - opens vbs-file with notepad) and %1 (without exclamation marks - does the same as without and still spaces are not allowed).

Any suggestions? (other than removing spaces from the filename..)

Af: Peter Munk 1. jul 2017

RE: Execute Wscript as a document/template

Hi Peter,
I have no work around for you in 7.5
7.5 is a long time ago and hard for me to setup an environment for.
So I tried this with 8.1

The good news: It worked for me. Since 8.0, Win uses the netserver docplugin. Much has changed inside in this area. I expect it has something to do with this.


The bad news: You will now need to use the Web Admin client to add document templates and the More tab is no more! You cannot anylonger associate a particular app with a doc tmpl. You are going to have to associate WScript.exe to .vbs files from the OS. Not what I wanted but needed to do for this test. It also took forever to change! This is on Windows 10.

 

My doctmpl was: script template[1].vbs
My company name used was: My favourite!
My doc header was: script template 1
The file name generated was: my fav_scrip_script template 1.vbs

My script content: WScript.Echo "<name>"

It gets executed:

 


I tried making a new file type, .wst, .wscript and associate it with WScript.exe but the OS wouldn't accept it - after spinning for several minutes. Beats me!

/conrad

Af: Conrad Weyns 2. jul 2017