Coming soon: Your brand new Help Center & Community! Get a sneak-peek here

Uninstall SO8 Web and it will remove .net 4.0

Hi,

We just encountered an issue in our production enviroment where we host SuperOffice installations for multiple customers.
We uninstalled SuperOffice 8 Web (SR1) and during the uninstallation it disabled .net 4.0 for the whole IIS, causing a server downtime.

So, my question is, can someone please let me know the reason why SuperOffice Web would disable it during an uninstallation?
I know that during the installation it will try to install it, and thats fine. But its really not OK that it disables it since that impacts multiple sites/systems.

 

RE: Uninstall SO8 Web and it will remove .net 4.0

Hello Pär. 

In order to investigate this issue, I require more information from you. 

Can you clarify a bit what you mean happen? You state in the headline that .net 4.0 is removed, while in the description, you state that it is disabled for entire IIS. How is it disabled? 

--

HansO

Af: Hans Oluf Waaler 19. maj 2016

RE: Uninstall SO8 Web and it will remove .net 4.0

Hi there :)

Aah, yes, the subject is a bit missleading, the description is correct.

This is more down to details what happend and the situation:

We have one IIS, hosting X number of SuperOffice/CS installations, each customer have their own site, appool, and seperated installations and folders in Windows.

We are hosting both SuperOffice 7 and SuperOffice 8 enviroments.

We upgraded a customer, installing a brand new installation of SuperOffice 8 Web, during the installation the command promts appears briefly saying that its installing .net 4.0 (although already installed)
Then for different reasons we had to uninstall that SuperOffice 8 Web installation, during the uninstallations are alarms went off that all the sites have gone offline and when we tried to reach them we recived an error 500.
We couldnt access any mapphandlers and everything was pointing that the asp.net or .net stopped working all together.
We restarted the server but still the same, then it hit me that the uninstallation might have caused a disable on something, so i reinstalled SO 8 web real quick and the secound after the command promt showed saying installing .net 4.0 had appeard, the iis was once again responsive and started to work.

Do you want me to dig up some iis logs? I talked to SuperOffice Sweden and they had heard of some customer that had ran into the exact same thing, im afraid i dont know the specific about that case though

 

Af: Pär Pettersson 19. maj 2016

RE: Uninstall SO8 Web and it will remove .net 4.0

Hello, Pär. 

We have "successfully" been able to reproduce the issue where other sites stop working after one site is uninstalled. Note that the sites shared the same application pool (called SuperOffice). Can you please check which app pools the affected sites were running as? When the app pool was missing, inspecting the handler mappings failed. Browsing the site externally gave a 500 error, but browsing the site locally gave error message related to missing protocolMapping configSection (which only exists on >= 4.0 app pools). Re-creating the app pool made the sites work again. Note that the app pool is created during installation. 

We havent been able to reproduce the issue when you have several sites, but different app pools.

 

--

HansO

Af: Hans Oluf Waaler 27. maj 2016

RE: Uninstall SO8 Web and it will remove .net 4.0

Hi Olof,

All our sites are running on .net 4.0 appools

2  sites share an appol, but the other 6 have seperated appols.
Every site running 4.0 went down though 

Af: Pär Pettersson 27. maj 2016

RE: Uninstall SO8 Web and it will remove .net 4.0

Hello,

We have the same issue, we are hosting multiple installations on the same server (different app pools), but everytime we remove an installation, all the installation get a blank white screen until we run a repair on one of the installations.

It seems like the installer/uninstaller removes the .dll references globally.

The same is also true when upgrade one in installation, all the installations get a reset and everyone needs to login again.

None of this behavior was present with SO 7.5.

 

Thanks,

David

Af: David Hollegien 11. jul 2016

RE: Uninstall SO8 Web and it will remove .net 4.0

Good afternoon,

I realize this is an older topic but I was just wondering if anyone found a definitive answer for this post. I see the same symptoms in our own hosted solution environment as well. When one installation is uninstalled, other installations experience the same blank white screen even though they all reside within their own IIS site and have separate app pools.

A client of ours is also experiencing a related issue in which an answer here may help me determine the cause of their problem. When the client logs into SuperOffice Web, users are experiencing the same blank white screen as mentioned above. I fixed the issue once and everyting seemed to work fine for a couple of days. However, the issue returned less than a week later. The only solution I have found is to do a quick uninstall/install of the web components.

I am not sure if the two issues have a common link but if anyone has anything to add it may give me a starting point of where to begin.

Thank you.

Af: Brian Huelsman 8. sep 2021