Coming soon: Your brand new Help Center & Community! Get a sneak-peek here

Error opening an service attachment via Requests tab in SO Win


I have encountered a strange problem i wonder of anyone else have seen before.
The problem occur when you try to open an attachment (say an .pdf) in Service using SO Win and the request tab.

First we could not reproduce this error with our Windows (admin) account but thought it might had to do with the elevated rights so we got another Windows account with user rights and had no problem there either. This was tested last week of September but when we did another test last week we also got the error opening attachments (mainly .PDFs).
Meanwhile all the regular users was experience this error and have been doing so for a long time it seems.

When we did not have any error and chose to open the file it opened as expected:

Trying to download it we had no issue either:

But as of lately we now experience the same issue as the regualr users:

They mainly use SO Win but when trying to do the same in SO Web we saw the same error but after creating a GPO allowing their web site (*.<domain>) it worked just fine, both in IE11 and Chrome.
However the problem still occurs for SO Win.

So if i click on an attachment from CS in SO Win, what web component is used in the background?
What kind of exception is needed to open/download CS attachments via SO Win (run on a RDS)?

According to their IT they do not have any restrictions regarding downloads.

BR Rasmus


RE: Error opening an service attachment via Requests tab in SO Win

I am only guessing here but I suspect this might be a IE11 + CS code issue.
Win uses the IE11 Active X component in it's "internal" browsers.
(This is essentialy a black box for us)
Some CS expert might be able to figure it out though.
So I can only suggest that you log a support case.

Af: Conrad Weyns 2. nov 2020