Coming soon: Your brand new Help Center & Community! Get a sneak-peek here

MailLink problems with saving in Win 8.2R04

Hi

A customer with Citrix servers are struggeling with maillink in Outlook after upgrade to 8.2R04. The use the Win client and Outlook 2016.

When the try to archive a mail to So, they get a message (document not saved). I can see that the msg file is created in the user profiles temp folder and disappears again, but nothing is saved in so_arc.

The settings er tested just fine. The user can create and delete documents in the SO client. 

If we try to archive the email as an appointment, the Ok button is grey/inactive.

If we try to update an email addresse on a person from the maillink, the OK button is active but nothing happens when clicking it.

The debug log shows this:

OUTLOOK.EXE: EndWriteDocumentStream failed with exception. - Error: Service call Document.SaveDocumentEntity failed with exception
Document.SaveDocumentEntity.

OUTLOOK.EXE: Dokumentet ble ikke lagret SuperOffice.MailLink.Exceptions.SoDocumentErrorException: Failed to save document
at SuperOffice.MailLink.Client.FileUploadHelper.DoWork(Object sender, DoWorkEventArgs e)

Hi Ingar!

 

Could it a problem with user rights in SuperOffice? If you check in SuperOffice admin under Roles>Documents, what are the rights there?

Alternatively, is it a 32 or 64 bit Office?

Af: Emilija Vilija Treciokaite 4. jun 2018

32 bit Office

The user can both create and delete documents in the SO Client, so the roles should be just fine.

Af: Ingar Karlsen 4. jun 2018

Was it just an upgrade, nothing else has changed?

Af: Emilija Vilija Treciokaite 4. jun 2018

32 bit Office

The user can both create and delete documents in the SO Client, so the roles should be just fine.

Af: Ingar Karlsen 4. jun 2018

Upgrade and moving to new server's

Af: Ingar Karlsen 4. jun 2018

Did you delete the files in Roaming appdata/SuperOffice/MailLink afterwards? 

I would recommend to do that (delete the folder), close Outlook, restart SuperOffice, start Outlook from SuperOffice and try to archive.

Does it work now?

Af: Emilija Vilija Treciokaite 4. jun 2018

We have tried with a new user not logged on to the server before, so every file is newly created in the AppData folder.

But the same error with this user.

Af: Ingar Karlsen 4. jun 2018

We have tried with a new user not logged on to the server before, so every file is newly created in the AppData folder.

But the same error with this user.

Af: Ingar Karlsen 4. jun 2018

Did you reinstall MailLink on the server after the upgrade?

Windows client works without any issues?

Af: Emilija Vilija Treciokaite 4. jun 2018

We have tried with a new user not logged on to the server before, so every file is newly created in the AppData folder.

But the same error with this user.

Af: Ingar Karlsen 4. jun 2018

We have tried with a new user not logged on to the server before, so every file is newly created in the AppData folder.

But the same error with this user.

Af: Ingar Karlsen 4. jun 2018

Hi

I have the same issues with the same versions. Also moved to new servers...

Af: Gabriel Wiig 12. jun 2018

We figured it out.

When running Dbsetup to upgrade the DB from 8.0 to 8.2R04 we had to include In development steps. Then it worked.

So we just ran the DBsetup once more with those steps included.

When upgrading the DB with ServerSetup this is not an issue, just when running DBSetup.

Af: Ingar Karlsen 19. jun 2018