Coming soon: Your brand new Help Center & Community! Get a sneak-peek here

SOCRM.interop throws error when started via scheduled task

Dear support forum,

we are using SuperOffice 7.5 Sales and Marketing and I'm trying to complete a "call acitvity" via a console application using the SOCRM.interop dll from a nuget package.

(The idea behind this is to execute all scripts when setting this property which would not be the case if we set it via the database.)

The program runs fine when executed manually by a logged in user, but throws an error when started via a scheduled task.

Function: SOApplication app = new SOApplication();

Error: 

Exception: System.Runtime.InteropServices.COMException (0x80080005): Retrieving the COM class factory for component with CLSID {7265689D-043F-4930-BA99-0FFB9A8F91F1} failed due to the following error: 80080005 Server execution failed (Exception from HRESULT: 0x80080005 (CO_E_SERVER_EXEC_FAILURE)).

Windows Log:

Application Log 1: Application: SO_TicketToolApp.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.Runtime.InteropServices.COMException
at SO_TicketToolApp.Program.Main(System.String[])

Application Log 1: Faulting application name: SO_TicketToolApp.exe, version: 1.0.0.0, time stamp: 0x59e75014
Faulting module name: KERNELBASE.dll, version: 6.3.9600.17055, time stamp: 0x532943a3
Exception code: 0xe0434352
Fault offset: 0x00011d4d
Faulting process id: 0x208
Faulting application start time: 0x01d349744fa6500c
Faulting application path: {...}\SO_TicketToolApp.exe
Faulting module path: C:\Windows\SYSTEM32\KERNELBASE.dll
Report Id: a750b1c1-b567-11e7-80dc-005056bc770a
Faulting package full name:
Faulting package-relative application ID:

System Log: The server {7265689D-043F-4930-BA99-0FFB9A8F91F1} did not register with DCOM within the required timeout.

 

The job runs with highest priviliges and by an administrator user.

Server: Windows Server 2012 R2

We tried changing the DCOM Config for the SuperOfficeCRM, but nothing helped.

We also set a registry entry from this support entry https://support.microsoft.com/en-us/help/870655/you-may-receive-an-error-code-80080005----server-execution-failed--err

The first question is: Is it even possible to use the interop component in a scheduled task?

When yes, any ideas how to fix this?

Thanks in advance.

RE: SOCRM.interop throws error when started via scheduled task

Hi Sebastian,
may be you have figured it out....
I have never used the Task Scheduler for much so I tried it now.
I used VBSEdit to make a simple script accessing the app like this:

_____________

Set app = CreateObject( "SuperOffice.Application" )
If Not app Is Nothing Then
..........
Else
    WScript.Echo "Error getting application object"
End If
______________

Then converted it into an executable and used it in the Task Scheduler.
It had no issues launching SoCrm and executing.
That said, if the script must launch the app, then the outcome may depend on what you want doing. This is because as soon as the COM application object is created, the rest of the script will continue executing. But SoCrm has not quite had the time to restore its full GUI yet. This will typically affect the Current system..
Nevertheless, SoCrm launched and was instantiated without any problems.
As long as everything is properly registered, I am inclined to say that it should work from a scheduled task.
(I am on Windows 10 with our latest 8.1)
Conrad



Af: Conrad Weyns 19. nov 2017