We’ve developed some resources to help you work effectively from home during COVID-19 Click to learn more

Cannot connect to Pocket after upgrade to SuperOffice 8.5R04

After upgrading a customer from 8.2R02 to 8.5R04 no users can log in to Pocket. We are getting "Unable to connect to https://superoffice.customer.no/sales/remote/services86" in Pocket. Does anybody have a suggestion how to go forward on this? 

* The customer does not run Single Signon on Web (currently uses SuperOffice Windows as primary client)
* We have verified that there is only Anonymous Authentication on the SuperOffice website. There were an additional "Basic Authentication" on the website that we removed after upgrade. Putting this back, does not change the message. 

* We have verified that the Symmetric keys are identical on all Netserver configs

* As you see above, we run the default Webservice inside SuperOffice Web for Pocket, not a dedicated NetServer
* We have not overridden the Pocket-URL in SOWeb

* We have tried to set the versions above 8.4 to false in ServiceVersion.xml to check if there could be anything in the routing/firewall that denied using 8.6 (8.4 was used before), this gives the same message - but service84)

* We are able to authenticate with an explicit user from a local testapplication to a service in services86 

* The problem comes with Pocket that is already installed or from a fresh new Pocket client

Appreciate all comments on this :) 




Cannot connect to Pocket after upgrade to SuperOffice 8.5R04

OK, so this seemed to be a routing issue. Before upgrading SuperOffice, this worked well - also with https (i got a tip that Pocket is not fond of https, but we try to run https everywhere and Pocket works with https). 

But after upgrading the server, we could not log in. This installation has not published SuperOffice to the public, only what is needed to run Pocket and Service it passed through the firewall. There must have been some changes from 8.2 to 8.5 - because when we removed some of the limitations on the traffic, it worked. 

Does anybody know exactly which services and calls Pocket needs to run? And what extra has to be accessible after this upgrade from 8.2 to 8.5? 

Av: Atle Bjerck 4. nov 2019

RE: Cannot connect to Pocket after upgrade to SuperOffice 8.5R04

Pocket only needs the Netserver services URL. Did you try to open an endpoint from the Pocket device in a browser like https://superoffice.customer.no/sales/remote/services86/contact.svc? 
My guess is during the upgrde the site name was changed and the SSL sertificate is still on the old name and thus denied by the Pocket device. 

Av: Rob Jansen 7. nov 2019

RE: Cannot connect to Pocket after upgrade to SuperOffice 8.5R04

Hi Atle,

I am currently investigating a setup with a similar issue to what you are describing. Just out of curiosity; did you try to forward both crm.customer.com/sales/remote/ and crm.customer.com/sales/api in this restricted environment?

Av: Andreas Mistereggen 2. apr 2020

RE: Cannot connect to Pocket after upgrade to SuperOffice 8.5R04

Hi Andreas. This problem was solved by opening for more addresses in the firewall - but I did not get the details on which URLs they had to allow. But my opinion is that there is a reqirement for more than the services address after R04 even if I havent seen any documentation on this... 

Av: Atle Bjerck 3. apr 2020