We’ve developed some resources to help you work effectively from home during COVID-19 Click to learn more

compactMode believes Sales is hosted on HTTP

Hello, 

I'm trying to figure out how the callbackUrl is decided for compactMode. 
Spesifically i notice that when accessing https://mydomain/scripts/rms.fcgi/compactMode#mainpage the requestUrl sent from the browser is this: 
http://mydomain/superoffice/Security/Login.aspx?ReturnUrl=%2fsuperoffice%2f%3fservice%3f%252Fscripts%252Frms.fcgi%253F_sf%253D%2526action%253DcompactModeCallback%2526method%253Dmainpage%2526desktopMode%253D1%26fromCs%3d1 

This gives me mixed-content-issues in the browser: 
 And if i enable unsafe scripts it gets blocked by CORS policy: 
 
In the database both cgi_url and cgi_url_internal in crm7.config are set to https. 
In SuperOffice Admin the baseUrl-address is set to use https as well. 

Why does compactMode try to access/forward to the SuperOffice login-page on HTTP, and is it possible to override this somehow? My only guess here would be that SuperOffice is internally hosted on HTTP, with a proxy frontend, so maybe its hardcoded that it uses the binding on the site?

I tested this on a desktop-computer and if I have a valid session (log in to SuperOffice) and then open compactMode it works at it should, so its the forward to the Sales login-page that fails. 


//Eivind


RE: compactMode believes Sales is hosted on HTTP

So, found a possible workaround while i figure this one out. If you use this URL (instead of going do compactMode directly), you get the login-page for SuperOffice: 
http://mydomain.com/superoffice/Security/Login.aspx?ReturnUrl=/scripts/rms.fcgi/compactMode#mainpage  

After logging in i go to the returnUrl, which is compactMode, which works.

//Eivind


Av: Eivind Johan Fasting 3. jan 2020

RE: compactMode believes Sales is hosted on HTTP

hi,

In the registry table there is flag: forcehttps (think it is called that) , put that to 1.

That might help to solve your situation.

(whn using http => https proxy (eg running the SO installation in http -mode but putting it behinde a https proxy) this solves issues with SCIL implementations, like the marktingbutton (edit/send etc) that does not understand that calls are made on the https-adress.

 

/Anders

 

Av: Anders Larsson 3. jan 2020