CRM Triggers when using windows Auth returns 401

Hi,

We have ran into the following issue.

When using Trigger for CRM functions we get the follow error, even though the script doesnt do anything.

 

 

 

We have Windows Auth enabled for the NetserverAD, Scripts and Sales, but thats it.

Is there a logical bugg that the trigger tries to call on the netserverAd, but does not pass the windows auth and therefor returns the 401?

All CS related triggers works just fine, its only from S&M

Regards
Pär Pettersson

 

 

RE: CRM Triggers when using windows Auth returns 401

Hi Pär,

just want to mention that you are no longer required to have NetServerAD in version 8.1 (?) to use SSO.

The only requirement is that Service uses a NetServer that's not on SSL.

 

Why isn't the entire site using Windows Authenticated authorization?

Av: Simen Mostuen Iversen 23. aug 2018

RE: CRM Triggers when using windows Auth returns 401

Intresting, didnt know that.
Do you know if this is mentioned anywhere?

We will try to set it up like that and see if we still experience the issue

Av: Pär Pettersson 23. aug 2018

RE: CRM Triggers when using windows Auth returns 401

Hello, 

You need to have blogic.fcgi (or.exe if you dont use .fcgi) set as annonymous, at least that is what Sverre told me in a post some months ago. 
I will try to find the thread so you can read his explanation 


//Eivind

Av: Eivind Johan Fasting 23. aug 2018

RE: CRM Triggers when using windows Auth returns 401

https://community.superoffice.com/en/developer/forum/rooms/topic/superoffice-product-api-group/crm-web-application/crmscript-on-sale/ 

"I guess the problem is when NetServer is accessing Service to execute the CRMScript. If you enable Anonymous acess as well as Windows authentication for blogic.fcgi then I think it should work."

Av: Eivind Johan Fasting 23. aug 2018