Slow login in client when there is no sale registered for a user

Hi,

On the same database we have sometimes seen long login times (up to 10-15 minutes) when the diary is active. Also logging in to f.i. the company screen and than switching to the diary takes minutes. Current version is 8.2 R3. It only happened a few times in last years, like said in different versions and every time for a specific (new) user. Also happens in the Win client when logging in with the same account.

Tested cleaning userpreference for the user, completing all appointments for the user, checked visiblefor, ckecked history. No scripts that use the diary. No useable info in logfiles.

It is solved by adding a dummy sale record for the user. This is a workaround the customer can live with, but we still want to know what's happening. Anyone seen this before?

 

Regards,

Rob

RE: Slow login in client when there is no sale registered for a user

I have never heard about this.

How did you come up with trying to add a sale?

Av: Erik Eide 1. okt 2019

RE: Slow login in client when there is no sale registered for a user

I didn't, Alexander Hesselberth did discover this. Can't recall how he got to it, I will ask him.

Av: Rob Jansen 1. okt 2019

RE: Slow login in client when there is no sale registered for a user

Hi Erik,

I was involved in this case, but that was a long time ago.(4 years) The issue we had then was in the 7.1 Windows client and when a new user tried to log in, it took minutes. After the user was logged on, the speed in SuperOffice was normal.

When the user was moved to another usergroup, the problem dit not ocure. I got a copy of the database and was able to reproduce it in a VM.International Support was involved in the issue but had problems restoring the database.

Because it worked normal when the user was in another group I thought it might be caused by sentry or some complex rol setup. At some point I noticed the new user had no sale records created (Can't remember why I checked this) and after I created a sale it worked as normal.

Last week Rob reported a slow login issue at this customer but now it occurred in 8.2 Web. I remembered the case we had in 2015 and the also in this case creating a sale solved it.

Av: Alexander Hesselberth 1. okt 2019