Updated Mail Link leaves Company empty by default

Yesterday I got an update for my Web Tools. Now, when I archive an email to an existing customer, Mail Link leaves the Company Field empty by default, even when I choose a contactperson that is attached to a company.

Is this by design or a small bug? ;)

 

Hey Rick. Thanks for the post!

As you know, SuperOffice has been updated to support working with stand-alone people and a person no longer need to be associated with a company in SuperOffice. (Internal name: Personize)

This causes some changes down the line for other integrations. Integrations like MailLink. So with the update released yesterday, MailLink now contains limited support for stand-alone people too. (More coming soon)

While that's a pretty "minor" change, it creates some new scenarios and it does affect the visual hierarchy of the dialogs somewhat. We've had some discussions internally about what we should do about those new scenarios and use-cases and how they should be presented visually.

I guess this "good old" use-case didn't receive similar discussion, and may have ended up like this more by conincidence than by design.

From what I can tell:

  1. We are also archiving on a company. No associations are getting lost here.
  2. The archived email will still be available in the company's activity-archive in SuperOffice, even though the target is a person.

Based on that, I think it makes sense that we should have populated the company-area too here, for clarity and to avoid confusing users.

Edit: We will ship a new MailLink with bugfix.

Sounds good?

Av: Jostein Kjønigsen 20. jun 2018

Thanks for your reply Jostein! :)

Let me first start by saying it's great to have that option in Mail Link, to archive email on a contactperson without a company.

But it would be nice if the Mail Link setting would check the SuperOffice setting, whether or not a company is mandatory for a contactperson.

In OneDB, it's still mandatory to attach a contactperson to a company when you want to create a new contactperson. But via Mail Link it isn't mandatory. I think that will confuses a lot of people. :) (I already had some collegues at my desk this morning who thought Mail Link was bugged ;) )

Av: Rick van Overbeek 20. jun 2018

Let me first start by saying it's great to have that option in Mail Link, to archive email on a contactperson without a company.

If SuperOffice allows it, MailLink should allow it. Otherwise we have a inconstent and confusing offering :)

But it would be nice if the Mail Link setting would check the SuperOffice setting, whether or not a company is mandatory for a contactperson.

We do. But this setting only applies when creating new contacts, not when archiving stuff and associating with existing contacts.

See the difference?

In OneDB, it's still mandatory to attach a contactperson to a company when you want to create a new contactperson. But via MailLink it isn't mandatory.

That's actually wrong :)

Right now, MailLink does not support creating stand-alone people in SuperOffice, even if the installation is configured to allow it. We plan on adding support for this too this (together with other improvements) in an upcoming WebTools release.

I think that will confuses a lot of people. :) (I already had some collegues at my desk this morning who thought Mail Link was bugged ;) )

That's good feedback and a good argument for changing this back. We definitely don't want to confuse our users.

Edit: We will ship a new MailLink with bugfix.

Av: Jostein Kjønigsen 20. jun 2018

Hi guys, we're also seeing this (OnSite 8.3 R01).

Jostein, you say that the e-mail is connected to the Company, even if you just select the Person, but that is not our experience here.

Here is an e-mail I've archived. Anders is a person which is connected to a Company. When archiving the person is suggested by MailLink, while Company field is blank. If I just click OK to archive the document in SuperOffice is only connected to the person, not the Company.

The preference "Mandatory company on contact" is set to NO in this database.

 

Av: Frode Lillerud 20. jun 2018

Hey Frode.

Thanks for your report.

Like I told Rick, that preference only affects the creating of new contacts. It has nothing to do with how doucments, tasks or emails are associated with existing contacts in SuperOffice.

Basically the value of that preference doesn't matter either way for MailLink, nor should it.

That said... If we are not getting our associations stored correctly, then that makes this a bit more critical in my opinion and it's unfortunate that this was not caught during testing.

I'll look into what we can do about that, and within what time-frames.

Av: Jostein Kjønigsen 20. jun 2018

Just wanted to add: We consider this to be a major bug and are giving this full attention now.

If you archive an email on a person connected to a company, this email must also be available in the company activity archive.

We will not ship 8.3 R02 for Onsite (eta tomorrow) before this has been solved.

 

Thank you so much for bringing this to our attention.

Av: Erik Eide 20. jun 2018

Hey Erik,

Could you also pull the newest web tools / mail link version that has this issue? since the update pop-up also shows up for OnSite customers.

 

Thanks,

David

Av: David Hollegien 20. jun 2018

The update has already been pulled.

If you check the SuperOffice Download Service, the latest version available now, is the same version we shipped in May:

https://www3.superoffice.com/DownloadService/

We already have a fix for this issue, and when that has been tested and approved, we'll issue a new update.

Av: Jostein Kjønigsen 20. jun 2018

Great to hear this is being resolved Erik! 

Av: Rick van Overbeek 21. jun 2018

Hey Rick and Frode!

We've now pushed a new release which should fix this issue.

Please let us know if you still experience issues.

Av: Jostein Kjønigsen 22. jun 2018

Hello,

Just installed the new version and the issue is fixed, thanks for the quick response!

Av: David Hollegien 22. jun 2018