We’ve developed some resources to help you work effectively from home during COVID-19 Click to learn more

8.1 DBSetup.exe gives "The path is not of a legal form" when doing upgrade?

Hi, 

as our consultants are testing out 8.1 we're all getting this error when using DBSetup.exe to do an Upgrade.

Here I've just pointed the ODBC to an existing database, selected "Upgrade, if there....", and clicked OK.

 

What is the path it is trying to read?

Is SO_arc located on a share? Then it may be failing when writing to the logfile, try adding this to SuperOffice.ini

[Error]
Logpath=somelegalpath\somelegalname.log

 

(replace the "somelegalpath/somelegalname" part ;-) )

Av: Margrethe Romnes 20. okt 2017

SO_ARC is not on a share.

So in my SuperOffice.ini, located in the same directory as DbSetup.exe, I added the two last line here;

[ServerSetup installation]
ServerSetup version=8.1.6499.1437
ServerSetup folder=c:\SuperOffice8\Server
[SuperOffice]
GlobalPrefix=CRM8
Datapath=ODBC:superoffice8
Archivepath=c:\SuperOffice8\SO_ARC
[Client]
PrefLang=US
PrefMailClient=Outlook2007
PrefWordProcessor=Word2007
[ODBC:superoffice8]
Database=SuperOffice8
DatabaseDriver=SQL Server Native Client 11.0
DatabaseServer=.\SQLEXPRESS
[Error]
LogPath=C:\temp\test.log

And that fixed it! Thanks!

Does it default to some other logpath if those lines aren't there?

Av: Frode Lillerud 20. okt 2017

We have a bugreport on it and it will be investigated on Monday, stay tuned :)

Av: Margrethe Romnes 20. okt 2017

Hi

Also trying to export to a .sdb file fails if LogPath is not set in the SuperOffice.ini file.

This means that the trying to export the database using a batch file with Dbsetup.exe with parameters also fails. Is there a work around for this?

 

Thanks

Cham

Av: Cham Mistry 2. nov 2017

Hi Cham,

next release will have a fix for this, but the current workaround even for running dbsetup with command line is to add the Error section to the SuperOffice.ini.

Av: Margrethe Romnes 3. nov 2017

Hi,

  I have now registered the bug with the issue id 54898 . 

Av: Mindaugas Kaucikas 10. nov 2017

Fixed in the latest code.

Av: Martin Pavlas 14. nov 2017

Hi

dbsetup.exe from command line does not work.
I have entered the logpath in superoffice.ini, and regular use of dbsetup now works as it should.

This is a major issue when I update all our customers simultaneously on our servers

 

Here is the log file from the logpath of superoffice.ini:

171115 22:28:20 [DBSetup.exe] DbSetup: export 
171115 22:28:20 [DBSetup.exe] Calculate SODirPath=c:\Program Files (x86)\SuperOffice\SuperOffice Server\SuperOffice.INI. Src: SSuperOfficeIni::InitVariables at SuperOfficeIni.cpp v line 332 

171115 22:28:20 [DBSetup.exe] Loading superoffice.ini from path 'c:\Program Files (x86)\SuperOffice\SuperOffice Server\SuperOffice.INI'.
171115 22:28:20 [DBSetup.exe] ConfigFile=c:\Program Files (x86)\SuperOffice\SuperOffice Server\SuperOffice.CONFIG. Src: SSuperOfficeIni::InitVariables at SuperOfficeIni.cpp v line 369
171115 22:28:20 [DBSetup.exe] ConfigFile=c:\Program Files (x86)\SuperOffice\SuperOffice Server\SuperOffice.CONFIG. Src: SSuperOfficeIni::InitVariables at SuperOfficeIni.cpp v line 391
171115 22:28:20 [DBSetup.exe] Loading superoffice.config from path 'c:\Program Files (x86)\SuperOffice\SuperOffice Server\SuperOffice.CONFIG'.
171115 22:28:23 [DBSetup.exe] Verify Lang Code ''. Src: SSuperOfficeIni::VerifyLangCode at SuperOfficeIni.cpp v line 1140
171115 22:28:23 [DBSetup.exe] Verify Lang Code 'US'. Src: SSuperOfficeIni::VerifyLangCode at SuperOfficeIni.cpp v line 1140
171115 22:28:23 [DBSetup.exe] Set Lang Code 'US'. Src: SSuperOfficeIni::SetLangCode at SuperOfficeIni.cpp v line 1193
171115 22:28:23 [DBSetup.exe] _SetUICulture 'US'. Src: NSSoSession::_SetUICulture at NSSoSession.clr.cpp v line 228
171115 22:28:23 [DBSetup.exe] Attempt to set error log path to . overriden by INI file setting. Src: SErrorManager::SetErrorLogPath at Terror.cpp v line 1959

Av: Pål Skodjevåg 15. nov 2017

hi,

what command do you use?

DBSetup.exe upgrade ODBC db_user db_user_pass schema works fine for me after logpath is defined.

Av: Darius Margelis 16. nov 2017

Hi

Just upgraded to 8.1.6514 and using DBsetup from command line is still failing (with or without LogPath)

using:

DbSetup.exe EXPORT ODBC:SuperOffice7 crm7 xxxxx crm7 E:\Dumper\SuperOffice.sdb

Any suggestions?

Have couple of Customers who use SQL Express and rely on this for backup!

 

Thanks

Cham

Av: Cham Mistry 22. nov 2017

Hei,

Did a test export, works fine both via GUI and CMD.

Could you try running command without [ODBC:] part?
DbSetup.exe EXPORT ODBC:SuperOffice7 crm7 xxxxx crm7 E:\Dumper\SuperOffice.sdb

Av: Darius Margelis 22. nov 2017

Hi

Just upgraded to 8.1.6514 and using DBsetup from command line is still failing (with or without LogPath)

using:

DbSetup.exe EXPORT ODBC:SuperOffice7 crm7 xxxxx crm7 E:\Dumper\SuperOffice.sdb

Any suggestions?

Have couple of Customers who use SQL Express and rely on this for backup!

 

Thanks

Cham

Av: Cham Mistry 22. nov 2017

Hi,

 I have been trying to upgrade a SuperOffice Database from 8.0 to 8.1. I had the same issue and adding the Log Path to the .INI file worked for us. However, I am noe getting the following error: 

 The index 'IDXSmsSession_key' is dependent on column 'session_key'.

ALTER TABLE ALTER COLUMN session_key failed because one or more objects access this column.

 ConfigFile=c:\SuperOffice\SuperOffice 7 Server\SuperOffice.CONFIG

 ConfigFile=c:\SuperOffice\SuperOffice 7 Server\SuperOffice.CONFIG

 Loading superoffice.config from path 'c:\SuperOffice\SuperOffice 7 Server\SuperOffice.CONFIG'

Verify Lang Code ''

Verify Lang Code 'US'

Set Lang Code 'US'

_SetUICulture 'US'

Attempt to set error log path to . overriden by INI file setting

 

Please can you advise where I have gone wrong and how to resolve this error?

Cheers

Rich

Av: Rich Hacker 6. dec 2017

Hi Rich,

I don't have a complete answer, but might send you in the right direction.

The table you're having trouble with is crm7.sms. It has a column called session_key, and an Index named IDXSmsSession_key.

In an early 8.1 version I had problems upgrading because the session_key column contained NULL values. I believe it has been resolved since then, because we have been able to upgrade our production environment even with NULL values in that field. 

So check the crm7.sms.session_key field, and perhaps you can clean up something there.

Av: Frode Lillerud 6. dec 2017