Error during ejournalCron.exe jobs


We have recently been made aware of an issue with the ejournalCron.exe jobs in our environment.

It stops fairly early in the process with the following error and does not continue:

[04816] [(System) ] [ejournalCron] 2019-12-05 20:40:24.237 [13.669] [13.669]: ejournalCron 1.0: DbODBC::FatalException (Query: select [reply_template_attachment].[id] from reply_template_attachment where ((([reply_template_attachment].[attachment_id] = ?) and ([ticket_attachment].[attachment_id] = ?)) and ([ticket_attachment].[id] <> ?)). Error:[Microsoft][ODBC SQL Server Driver][SQL Server]The multi-part identifier "ticket_attachment.attachment_id" could not be bound. ('1689', '1689', '1736')) in :-1

The id's it refers to at the very end of the error ('1689', '1689', '1736'), seems to be different almost every time.

I am not entirely sure how long this has been present, but given that we have deleted tickets from February 2016, I would say it never worked to begin with.

We are on version 8.4 R07.


Do you know how we can solve this issue? Ideally permanently as this is a rather pressing issue GDPR-wise :)

Thank you so much!

RE: Error during ejournalCron.exe jobs


This is a bug fixed in 8.4 R8

Av: David Hollegien 9. dec 2019

RE: Error during ejournalCron.exe jobs

Hi David,

Many thanks for the swift reply.

I tried searching the community and didn't find it there, but it never occured to me to check the bug reports.

Thanks again!

Av: Markus Moripen 9. dec 2019