http error 404.3 not found CS Installation

I've set up CS under the same domain as superoffice web following this url:

https://community.superoffice.com/en/technical/documentation/install-upgrade/service/manual-steps-service/

The netserver runs under default website (http), while superoffice and service is set up under own site (https)

I only get the following error messages:

i've checked that .svc handlers are in place, 

All IIS roles/features are installed

RE: http error 404.3 not found CS Installation

Where are you getting this message? /scripts/rms.fcgi?

And what does console say?

Av: Hans Wilhelmsen 14. mar 2017

RE: http error 404.3 not found CS Installation

On /scripts/rms.fcgi? yes and also when opening the maillings from superoffice.

Av: Gabriel Wiig 14. mar 2017

RE: http error 404.3 not found CS Installation

So you have fcgi handler mappings on the virtual application "scripts"?

CGI is enabled and allowed to execute?

Av: Hans Wilhelmsen 15. mar 2017

RE: http error 404.3 not found CS Installation

CGI is enabled and set to execute

But i see that i am missing the handlers for fcgi in my IIS.....

Av: Gabriel Wiig 15. mar 2017

RE: http error 404.3 not found CS Installation

You've verified that your Application Pool is using .NET 4.0? 

Av: Simen Mostuen Iversen 15. mar 2017

RE: http error 404.3 not found CS Installation

yes the app pool is using .net 4.0

Av: Gabriel Wiig 15. mar 2017

RE: http error 404.3 not found CS Installation

It's difficult to know what's wrong without looking at the setup myself.

But you've verified that the application "Scripts" in your Service Site has everything checked on Handler Mappings -> Edit Feature Permissions.

How's the Handler Mappings on the Site?

Also, if you click the root server and click "ISAPI and CGI Restrictions" and Edit Feature Settings, is "Allow unspecified CGI modules" checked?

Av: Simen Mostuen Iversen 15. mar 2017

RE: http error 404.3 not found CS Installation

Gabriel, you are saying that you are missing the .fcgi handlers?

Does that mean it works if you go to rms.exe?

If the problem is only with FCGI, then you can install those handlers using "upgrade.exe -onlyFCGI"

Av: Frode Lillerud 15. mar 2017

RE: http error 404.3 not found CS Installation

I had this one yesterday in a blank demo VM as wel. I solved it by selecting the server name in IIS Services manager and double click on ISAPI and CGI Restrictions. At the right top you click on Edit Feature Settings. In the new window that is opened you select both options (Allow unspecified CGI modules / ISAPI modules)

Av: Alexander Hesselberth 15. mar 2017

RE: http error 404.3 not found CS Installation

Just to add on Alexander Hesselberth answer, "Allow unspecified ISAP modules" isn't necessary. "Allow unspecified CGI modules" is the one you'll need to have checked :)

Av: Simen Mostuen Iversen 22. mar 2017

RE: http error 404.3 not found CS Installation

i ended up uninstalling cs, and installed it normally with superoffice on one site and service on another. That worked.

I think i'll wait for the 8.1 before using the same site

Av: Gabriel Wiig 22. mar 2017

RE: http error 404.3 not found CS Installation

Hi all,

today I try to install the Beta of 8.1 with FCGI and I have the same problem. I allways had problems in the past when I try to use FCGI. Most of our installation run with EXE files because of the big trouble we have with FCGI. 

I checked all mentioned tipps but nothing solves the problem. So I this isn´t a SuperOffice 8.0 problem. It is an configuration problem inside IIS. Unfortunately I am not an IIS expert, so I will keep on using the EXE mode if the customer is okay with it. 

Av: Christian Wyrwich 26. jul 2017

RE: http error 404.3 not found CS Installation

i currently also made a fresh installation on Win 2016 and have the very same error.

but i could solve it, with running upgrade.exe again with cmd as admin 

with "path\upgrade.exe" -onlyFCGI

Av: Markus Tanner 2. okt 2017